Getting Started with Lua Corovel

A quick overview to get up-and-running with Lua Corovel

Table of Contents

[toc indent=20px minLevel=2]

Installation

Dependencies

Corovel is a library written in pure Lua. It requires the following Lua modules:

  • Lua 5.1 (5.2 should work too, though not tested)
  • LuaSocket

Optional installs:

  • Lua Lanes

Running Corovel

Launch your Lua file with Corovel like so:

  • lua corovel.lua main This launches ./main.lua inside of the main Corovel

  • lua corovel.lua commands.master This launches the file ./commands/master.lua inside of the main Corovel