Overview

Getting to know lua-json-shim.

Installation

Currently the file tries to load one of dkjson, cjson or json. (You can also edit the file to add your favorite json module)

Of course you will need to install a json module for it to work, eg:

-- some example json libs
> luarocks install dkjson
> luarocks install lua-cjson

Usage

local json = require 'dmc_lua.json`

If you setup your Lua PATH (preferred), it would be:

local json = require 'json`